Thank you for submitting your inquiry.
You can track the status of your inquiry here.
You may want to save your case's ticket: 611650_00mrhourcf3ncps6


    (Closed) OS: Windows 8.1 x64 (fresh, installed only 4 days ago
     
     
     
    3
    OS: Windows 8.1 x64 (fresh, installed only 4 days ago)
    CPU: Intel Core i7-4770K (4 cores, 3.5 GHz)
    GPU: AMD Radeon R9-270X 2Gb
    SSD drive

    1) What happened
    The Unity Editor hangs/freezes when I stop "Play mode". It happens always and only way to release Unity Editor is killing the "UnityShaderCompiler.exe" process (which is using 0% of CPU, 5488Kb of RAM). Then, after 5-10 seconds, Unity Editor become responsive.
    The most goddamn thing with this bug - it's also somehow lockdown some actions in OS - for example, opening Context Menu for folder in Windows Explorer is also hangs until "UnityShaderCompiler.exe" is killed!

    This never happens with Unity 4.4 and I'm sure it's not related to sockets/threads we're using in the game. But if I open empty scene in this project, start and stop "Play mode" with it - everything seems to work correctly. So this happens only with actual gameplay scenes of our game.

    I've reproduced issue - the Editor.log should be included with this bug report.

    2) How can we reproduce it using the example you attached
    I'm sorry, I can't attach example project, because this happens only with our game project - VoidExpanse http://atomictorch.com - and it's not so easy for us to share full source code of this 1  year project. If it's required, you can sign NDA and then we will share it with you.
     
       
      To follow up on this case, send email to bugs@unity3d.com mentioning 'Case 611650' in the subject.
      Your Cases:
      Case Title Status Date Opened
      751541 Crash on prefab revert Open 12/8/2015 9:07 AM
      738374 A lot of GC-related crashes with our game Open 10/22/2015 4:58 AM
      706183 Unity 5.1.1 broke input for Linux standalone Closed 6/21/2015 3:39 PM
      624109 -e TL/DR: game launches on wrong monitor in 4.5.2p2 & 4.5. Open 8/4/2014 6:39 PM
      611650 OS: Windows 8.1 x64 (fresh, installed only 4 days ago Closed 6/4/2014 4:58 AM
      533124 user submitted bug Open 3/18/2013 11:35 AM